Roundup Tracker - Issues

Issue 2550792

classification
Title: export_csv_names doesn't handle Multilinks
Type: behavior Severity: normal
Components: User Interface Versions: 1.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Enhancing the functionality of the CSV export function 'export_csv_names'
View: 2550833
Assigned To: Nosy List: admin, ber, tekberg
Priority: normal Keywords: patch

Created on 2013-02-01 17:54 by tekberg, last changed 2016-06-25 21:11 by rouilj.

Files
File name Uploaded Description Edit Remove
ExportCSVNamesAction.py tekberg, 2013-02-01 17:54 Fix for the problem.
Messages
msg4782 Author: [hidden] (tekberg) Date: 2013-02-01 17:54
The export_csv_names extension doesn't handle Multilinks. Things like 
keywords show up as something like [8,9].

I have a fix for this in the attached file. Feel free to modify it, as 
long as it is an improvement.

Perhaps this could be a replacement for the file in:

  http://www.roundup-tracker.org/cgi-bin/moin.cgi/ExportCSVNames
msg4785 Author: [hidden] (ber) Date: 2013-02-04 09:39
Tom,
thanks for your report and the suggested improvement!

I think we need someone to test this with the current "tip" version
of roundup and then commit it to the core system it some way
as the export function from the webinterface is also affected.
However it may be that we need to support both versions of how
to export to csv.
msg5033 Author: [hidden] (tekberg) Date: 2014-03-14 13:53
Please mark this as closed or a duplicate of issue 2550833.
History
Date User Action Args
2016-06-25 21:11:29rouiljsetresolution: duplicate
2014-03-14 14:01:49bersetstatus: new -> closed
superseder: Enhancing the functionality of the CSV export function 'export_csv_names'
2014-03-14 13:53:58tekbergsetmessages: + msg5033
2014-03-10 19:03:42tekbergsetnosy: - schlatterbeck
2014-03-10 19:02:20tekbergsetnosy: + schlatterbeck
2013-02-04 09:39:31bersetkeywords: + patch
priority: normal
messages: + msg4785
nosy: + ber
2013-02-01 18:01:02tekbergsetnosy: + admin, - richard
2013-02-01 17:54:30tekbergcreate