Roundup Tracker - Issues

Issue 2550863

classification
Title: Release Roundup 1.5.1
Type: Severity: normal
Components: Infrastructure Versions: devel
process
Status: fixed Resolution: fixed
Dependencies: HTML attachments should not be served as text/html, HTML in error message from detectors gets escaped, recent setup.py change breaks installation of scripts without setuptools, unicode errors with experimental jinja2 template
View: 2550811

View: 2550847

View: 2550848

View: 2550898
Superseder:
Assigned To: schlatterbeck Nosy List: ThomasAH, ber, jerrykan, kerrigan@naturescapelawncare.com, schlatterbeck, techtonik
Priority: high Keywords:

Created on 2014-12-17 05:55 by techtonik, last changed 2016-01-11 21:56 by techtonik.

Files
File name Uploaded Description Edit Remove
unnamed techtonik, 2015-08-16 06:35
Messages
msg5176 Author: [hidden] (techtonik) Date: 2014-12-17 05:55
Master issue to track the work needed for releasing Roundup 1.5.1
msg5177 Author: [hidden] (techtonik) Date: 2014-12-17 06:31
http://issues.roundup-tracker.org/issue2550848 is blocking release.
msg5180 Author: [hidden] (ber) Date: 2015-01-05 15:54
Willing to help a bit, added the second release blocker to the
dependencies list.
msg5181 Author: [hidden] (ber) Date: 2015-01-05 15:57
Assigning to Ralf to steer the progress (he is the release manager after
all). ;)
msg5189 Author: [hidden] (ber) Date: 2015-01-17 20:40
If we are serious about the jinja2 template, we probably have to fix
the unicode problems with it before the release issue2550811
msg5277 Author: [hidden] (ber) Date: 2015-03-12 21:26
Fixed issue2550869 and issue2550877, now getting to issue2550811 next.
Any takers for the two others? :)
msg5351 Author: [hidden] (jerrykan) Date: 2015-08-10 12:41
From my reading of the issues:

 * issue2550848 is not fully resolved, but as resolved as it is going to
get for a v1.5.1 release
 * I'm of the opinion that issue2550811 should be dropped as a blocker
for a v1.5.1 release
 * issue2550847 just needs some consensus about the best approach

So if we just focus on resolving issue2550847 we should be able to cut a
new, and much overdue, v1.5.1 release?
msg5353 Author: [hidden] (ber) Date: 2015-08-10 13:39
On Monday 10 August 2015 at 14:41:57, John Kristensen wrote:
> So if we just focus on resolving issue2550847 we should be able to cut a
> new, and much overdue, v1.5.1 release?

Yes.
msg5355 Author: [hidden] (techtonik) Date: 2015-08-16 06:35
On Mon, Aug 10, 2015 at 3:41 PM, John Kristensen <issues@roundup-tracker.org
> wrote:

 * I'm of the opinion that issue2550811 should be dropped as a blocker
> for a v1.5.1 release
>

Thinking about this, I am in favor of recommending UTF-8 mode for Jinja2
setup. sys.setdefaultencoding('utf-8') sounds like a hack, but I fail to see
where exactly it is harmful.

http://stackoverflow.com/questions/28657010/dangers-of-sys-setdefaultencodingutf-8
msg5357 Author: [hidden] (jerrykan) Date: 2015-08-17 10:17
On 16/08/15 16:35, anatoly techtonik wrote:
>
> Thinking about this, I am in favor of recommending UTF-8 mode for Jinja2
> setup. sys.setdefaultencoding('utf-8') sounds like a hack, but I fail to see
> where exactly it is harmful.
>
> http://stackoverflow.com/questions/28657010/dangers-of-sys-setdefaultencodingutf-8

I've responded to this in issue2550811 to try and keep all the related 
discussion in the one issue.
msg5386 Author: [hidden] (jerrykan) Date: 2015-10-11 01:35
On 10/08/15 23:39, Bernhard Reiter wrote:
>
> Bernhard Reiter added the comment:
>
> On Monday 10 August 2015 at 14:41:57, John Kristensen wrote:
>> So if we just focus on resolving issue2550847 we should be able to cut a
>> new, and much overdue, v1.5.1 release?
>
> Yes.
>

I have now committed a solution for issue2550847 and closed the issue, 
which should allow a v1.5.1 release.
msg5389 Author: [hidden] (kerrigan@naturescapelawncare.com) Date: 2015-12-02 17:00
Is there an official timeframe for when 1.5.1 will be released? I can see 
from the changelog in sourceforge that it was planned for sometime in 
2015, is that still the case?

http://sourceforge.net/p/roundup/code/ci/bb97f61e1b73830eee1004622356ec41
ae80ea0b/tree/CHANGES.txt
msg5390 Author: [hidden] (kerrigan@naturescapelawncare.com) Date: 2015-12-02 17:02
Link didn't work the first time, didn't see a way to edit.

http://sourceforge.net/p/roundup/code/ci/bb97f61e1b73830eee1004622356ec41ae80ea0b/tree/CHANGES.txt
msg5391 Author: [hidden] (ber) Date: 2015-12-02 19:23
Am Mittwoch, 2. Dezember 2015, 17:00:49 schrieben Sie:
> Is there an official timeframe for when 1.5.1 will be released?

No. Except for a few blocker we are ready for a release.
The release will happen if some of us find the time to remove
the remaining issues and do the release itself.
Help is appreciated.
msg5392 Author: [hidden] (kerrigan@naturescapelawncare.com) Date: 2015-12-02 20:01
Which at this point is just the unicode issue (http://issues.roundup-tracker.org/issue2550811) 
right? Issue 2550847 is closed and issue 2550848 is still marked as new, but the last comment 
says "Commit 63c31b18b955 fixes this issue", so maybe it should be closed?

Reading through the comments on the unicode issue, it seems like it was left somewhat 
ambiguous as to whether there would just be a "hack" for the 1.5.1 release (since it only 
really affected jinja2) or if a "real" fix would be necessary before the release. Is this 
still up in the air?
msg5397 Author: [hidden] (ber) Date: 2015-12-02 20:15
Kerrigan,
from what I can see, you are right, it is only issue2550811 affecting the
jinja2 template. Would be cool to resolve this. I've just added a new comment.

Also closed issue2550848.
msg5398 Author: [hidden] (jerrykan) Date: 2016-01-04 01:56
I would just like to reiterate that I believe issue2550811 should be
dropped as a blocker for a v1.5.1 release.

It is now almost 2.5 years since v1.5 was released. I think it is much
more important to push out a new release as soon as possible than to
wait for "good" solution for an experimental feature.

Some workarounds have been mentioned in issue2550811 which we can point
users to until a proper fix is implemented when Jinja2 is no longer
considered experimental.
msg5399 Author: [hidden] (ber) Date: 2016-01-05 19:42
| I would just like to reiterate that I believe issue2550811 should be
| dropped as a blocker for a v1.5.1 release.

FWIW: I agree.

@schlatterbeck: When is the next point it time you can make a release?
  What is the main obstacle for you personally?

However I will try in the next hours to make progress with issue2550811
msg5415 Author: [hidden] (ThomasAH) Date: 2016-01-06 16:10
I consider issue2550898 (recent setup.py change breaks installation of
scripts without setuptools) a new blocker.
msg5421 Author: [hidden] (schlatterbeck) Date: 2016-01-07 07:20
On Tue, Jan 05, 2016 at 07:42:07PM +0000, Bernhard Reiter wrote:
> 
> Bernhard Reiter added the comment:
> 
> | I would just like to reiterate that I believe issue2550811 should be
> | dropped as a blocker for a v1.5.1 release.
> 
> FWIW: I agree.
I agree, too.

> @schlatterbeck: When is the next point it time you can make a release?
>   What is the main obstacle for you personally?
Mainly time.

Ralf
msg5423 Author: [hidden] (techtonik) Date: 2016-01-08 05:47
On Mon, Jan 4, 2016 at 4:56 AM, John Kristensen
<issues@roundup-tracker.org> wrote:
>
> John Kristensen added the comment:
>
> I would just like to reiterate that I believe issue2550811 should be
> dropped as a blocker for a v1.5.1 release.
>
> It is now almost 2.5 years since v1.5 was released. I think it is much
> more important to push out a new release as soon as possible than to
> wait for "good" solution for an experimental feature.
>
> Some workarounds have been mentioned in issue2550811 which we can point
> users to until a proper fix is implemented when Jinja2 is no longer
> considered experimental.

I some kind of agree on that as time proves that we are unable
to solve it. But!.. issue2550811 starts to become huge and getting
back to it becomes harder and harder as more text is added into
the thread. To avoid it being lost in the ocean of complexity it will
help to:

  1. reticket it
  2. clear summary of problem and results so far
  3. one line command/demo setup to reproduce the issue

This will easier entry allow for new people to investigate different
vectors and report results.
msg5454 Author: [hidden] (techtonik) Date: 2016-01-11 20:40
Almost there. =)
msg5455 Author: [hidden] (techtonik) Date: 2016-01-11 21:56
Done.
History
Date User Action Args
2016-01-11 21:56:11techtoniksetstatus: new -> fixed
resolution: fixed
messages: + msg5455
2016-01-11 20:40:53techtoniksetmessages: + msg5454
2016-01-08 05:47:28techtoniksetmessages: + msg5423
2016-01-07 07:20:13schlatterbecksetmessages: + msg5421
2016-01-06 16:10:06ThomasAHsetnosy: + ThomasAH
dependencies: + recent setup.py change breaks installation of scripts without setuptools
messages: + msg5415
2016-01-05 19:42:07bersetmessages: + msg5399
2016-01-04 01:56:52jerrykansetmessages: + msg5398
2015-12-02 20:15:37bersetmessages: + msg5397
2015-12-02 20:01:58kerrigan@naturescapelawncare.comsetmessages: + msg5392
2015-12-02 19:23:58bersetmessages: + msg5391
2015-12-02 17:02:04kerrigan@naturescapelawncare.comsetmessages: + msg5390
2015-12-02 17:00:49kerrigan@naturescapelawncare.comsetnosy: + kerrigan@naturescapelawncare.com
messages: + msg5389
2015-10-11 01:35:45jerrykansetmessages: + msg5386
2015-08-17 10:17:05jerrykansetmessages: + msg5357
2015-08-16 06:35:58techtoniksetfiles: + unnamed
messages: + msg5355
2015-08-10 13:39:57bersetmessages: + msg5353
2015-08-10 12:41:57jerrykansetnosy: + jerrykan
messages: + msg5351
2015-03-12 21:26:25bersetmessages: + msg5277
2015-01-17 20:40:08bersetdependencies: + unicode errors with experimental jinja2 template
messages: + msg5189
2015-01-05 15:57:10bersetmessages: + msg5181
2015-01-05 15:56:34bersetpriority: high
2015-01-05 15:56:26bersetassignee: schlatterbeck
nosy: + schlatterbeck
2015-01-05 15:54:16bersetmessages: + msg5180
2015-01-05 15:52:44bersetdependencies: + HTML in error message from detectors gets escaped, HTML attachments should not be served as text/html
2015-01-05 15:48:09bersetnosy: + ber
2014-12-17 06:31:52techtoniksetmessages: + msg5177
2014-12-17 05:55:40techtonikcreate