Roundup Tracker - Issues

Issue 2550866

classification
Title: "pip install --editable ." fails
Type: Severity: normal
Components: Installation Versions: devel
process
Status: open Resolution: remind
Dependencies: recent setup.py change breaks installation of scripts without setuptools
View: 2550898
Superseder:
Assigned To: jerrykan Nosy List: jerrykan, rouilj, techtonik, tonich
Priority: Keywords: patch

Created on 2015-02-04 19:51 by tonich, last changed 2016-07-31 20:41 by rouilj.

Files
File name Uploaded Description Edit Remove
roundup-setup.patch tonich, 2015-02-05 19:52
roundup-setup-2.patch tonich, 2016-05-11 11:54 v2
Messages
msg5204 Author: [hidden] (tonich) Date: 2015-02-04 19:51
steps to reproduce:

virtualenv ./venv
. ./venv/bin/activate
pip install --upgrade pip
pip install --upgrade setuptools
hg clone http://hg.code.sf.net/p/roundup/code roundup-code
cd roundup-code
pip install --editable .

result

error: [Errno 2] No such file or directory:
'/home/user/src/roundup-code/roundup-mailgw'
msg5205 Author: [hidden] (jerrykan) Date: 2015-02-05 03:09
I can confirm that I am seeing a similar issue when using the
-e/--editable option with pip. Invoking pip without the -e option does
not result in an error.

So there seems to be some issue with "development mode"[1] that needs
looking into a bit closer.


[1] https://pythonhosted.org/setuptools/setuptools.html#development-mode
msg5206 Author: [hidden] (tonich) Date: 2015-02-05 19:52
a worked solution in attachement:

works with "pip install ." and "pip install -e ."

tested with:
pip (6.0.7)
setuptools (12.0.5)
msg5207 Author: [hidden] (jerrykan) Date: 2015-02-06 01:14
This patch works for me as well.

In regard to the patch the use of the map function makes it non-obvious
what is going on (ie. requires more brain power to figure what is
happening). It may be simpler to make the equivalent changes in the
scriptname() function instead.
msg5212 Author: [hidden] (jerrykan) Date: 2015-02-10 07:10
I have slightly reworked the patch an push the changes to the repository:

  http://hg.code.sf.net/p/roundup/code/rev/cdfb1a3fb56f

Thanks for the original patch tonich
msg5427 Author: [hidden] (techtonik) Date: 2016-01-09 17:21
This change breaks scripts installation with `setup.py install`. Working 
on a proper fix for this.
msg5428 Author: [hidden] (techtonik) Date: 2016-01-09 21:11
The problem is that "pip install --editable ." converts setup.py from 
distutils to setuptools script and ignores build_scripts step.
msg5429 Author: [hidden] (techtonik) Date: 2016-01-09 21:13
setuptools instead calls its own install_egg_scripts() on "develop", which 
just copies the stuff verbatim.
msg5430 Author: [hidden] (jerrykan) Date: 2016-01-10 00:03
@techtonik also see issue2550898
msg5435 Author: [hidden] (techtonik) Date: 2016-01-10 07:13
@jerrykan aha, thanks for the pointer. I was about to report the same 
results. =)
msg5568 Author: [hidden] (tonich) Date: 2016-05-11 11:54
Another try
msg5601 Author: [hidden] (tonich) Date: 2016-06-14 07:16
ping. Please take a look on the second patch. It solves both problems
(this and #2550898).
msg5889 Author: [hidden] (rouilj) Date: 2016-07-31 20:41
Jerrykan or anatoly, can one of you evaluate the second path
on this issue and see if it solves the problem?

If so I'll get it integrated.


-- rouilj
History
Date User Action Args
2016-07-31 20:41:35rouiljsetnosy: + rouilj
messages: + msg5889
2016-07-31 20:30:28rouiljsetresolution: postponed -> remind
2016-06-14 07:16:19tonichsetmessages: + msg5601
2016-05-11 11:54:47tonichsetfiles: + roundup-setup-2.patch
messages: + msg5568
2016-01-11 22:01:23techtoniksetresolution: fixed -> postponed
2016-01-10 07:13:35techtoniksetdependencies: + recent setup.py change breaks installation of scripts without setuptools
2016-01-10 07:13:05techtoniksetmessages: + msg5435
2016-01-10 00:03:55jerrykansetmessages: + msg5430
2016-01-09 21:13:30techtoniksetmessages: + msg5429
2016-01-09 21:11:48techtoniksetmessages: + msg5428
2016-01-09 17:21:09techtoniksetstatus: closed -> open
nosy: + techtonik
messages: + msg5427
2015-02-10 07:10:19jerrykansetstatus: new -> closed
assignee: jerrykan
resolution: fixed
messages: + msg5212
2015-02-06 01:14:33jerrykansetmessages: + msg5207
2015-02-05 19:52:20tonichsetfiles: + roundup-setup.patch
keywords: + patch
messages: + msg5206
2015-02-05 03:09:23jerrykansetnosy: + jerrykan
messages: + msg5205
2015-02-04 19:51:55tonichcreate