Roundup Tracker - Issues

Issue 456940

classification
Title: ImportError: No module named detectors
Type: Severity: normal
Components: Web interface Versions:
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: richard Nosy List: richard
Priority: normal Keywords:

Created on 2001-08-30 18:29 by anonymous, last changed 2001-09-09 23:21 by richard.

Messages
msg11 Author: [hidden] (anonymous) Date: 2001-08-30 18:29
I installed on SuSe 7.1 (as root) without problem, and
set up an instance in /home/roger/roundup_instance as
per the instructions. Accessing via the web gives me
the following problem: 
  
  
 ImportError: No module named detectors
                                                                                                                                 
Python 2.1
                                                                                                                          
/usr/local/bin/python


A problem occurred while running a Python script. Here
is the sequence of function calls leading up to the
error, with the most recent (innermost) call first. The
exception attributes are:
      args = ('No module named detectors',)


/usr/local/lib/python2.1/site-packages/roundup/templates/classic/dbinit.py
in open(name='admin')

   83     issue.setkey('title')
   84 
   85     import detectors

       detectors = undefined
   86     detectors.init(db)
   87 

 /usr/local/bin/roundup-server in
inner_run_cgi(self=<__main__.RoundupRequestHandler
instance>)

  167 
  168         # initialise the roundupdb, check for
auth
  169         db = instance.open('admin')

       db = undefined, instance = <module
'_roundup_instance_1' from
'/home/roger/roundup_instance/__init__.pyc'>, global
open = undefined
  170         message = 'Unauthorised'
  171         auth =
self.headers.getheader('authorization')

 /usr/local/bin/roundup-server in
run_cgi(self=<__main__.RoundupRequestHandler instance>)

   86                 self.wfile.write("Content-Type:
text/html\n\n")
   87                 self.wfile.write(cgitb.breaker())
   88                 self.wfile.write(cgitb.html())

       self = <__main__.RoundupRequestHandler
instance>, global wfile = undefined, global write =
undefined, global cgitb = <module 'roundup.cgitb' from
'/usr/local/lib/python2.1/site-packages/roundup/cgitb.pyc'>,
global html = undefined
   89             except:
   90                 self.wfile.write("Content-Type:
text/html\n\n")

 
------------------------------------------------
Please let me know if you need further info...

Roger
msg12 Author: [hidden] (richard) Date: 2001-08-30 23:33
Logged In: YES 
user_id=6405

I'm afraid I can't reproduce this error. That the 
exception is raised in a module that is not supposed to be 
imported worries me. The templates directory of the 
library shouldn't be looked at after a correct init, which 
leads me to believe that the instance wasn't initialised 
properly. Could you please detail the exact steps and 
inputs used: from installing roundup to requesting the web 
page. For example, the following worked fine for me:

% python setup.py install
% roundup-admin init                            
Enter instance home: /tmp/test
Templates: extended, classic
Select template [classic]: 
Back ends: anydbm, bsddb, bsddb3
Select backend [anydbm]: 
Admin Password: 
       Confirm: 
% roundup-server -p9080 test=/tmp/test    
Roundup server started on ('', 9080)

I then request the web page http://localhost:9080/test/

msg13 Author: [hidden] (richard) Date: 2001-09-09 23:21
Logged In: YES 
user_id=6405

Closing - not reproducable and no further information 
provided.
History
Date User Action Args
2001-08-30 18:29:27anonymouscreate