Roundup Tracker - Issues

Issue 2550572

classification
Title: setting nosy=+foo on multiple issues gives them all the same exact nosy list
Type: behavior Severity: major
Components: Command-line interface Versions:
process
Status: fixed Resolution: fixed
Dependencies: Superseder:
Assigned To: rouilj Nosy List: kowey, rouilj
Priority: urgent Keywords:

Created on 2009-08-10 22:30 by kowey, last changed 2016-06-27 02:11 by rouilj.

Messages
msg3843 Author: [hidden] (kowey) Date: 2009-08-10 22:30
I'm just upstreaming http://bugs.darcs.net/issue1513

It seems that if you use the roundup-admin interface to 'set
issueXXX,issueYYY nosy=+foo', this has the effect of applying the same
exact nosy list to both issues, and not the intended effect of
separately appending the user foo to both nosy lists.

Luckily, roundup made it very easy to automatically correct this
(nice!), but this sort of thing might bite others in the future.
msg5648 Author: [hidden] (rouilj) Date: 2016-06-27 01:24
Yup this is true. Can be replicated in demo.py interface.

The code is in in roundup/admin.py:do_set() looks like
it may be the culprit.

I'll take this and see if I can figure out what's happening.

I am going to up this to major since it can cause incorrect data
that can be recovered from but ..

Thanks for the report.
msg5649 Author: [hidden] (rouilj) Date: 2016-06-27 02:11
Found and squashed the bug. A variable needed to be reinitialized every
time though a loop.

The first time through the loop the var had the value +foo.
Then it was evaluated to add the foo user to nosy and
the value was changed to exact value demo,foo (assuming demo
was the original nosy value for the first item designator). Then the
exact value got used to set the rest of the designators.

By resetting the variable to +foo for every designator it magically
works the way it was intended.

checked in: ca3e56590fcd
History
Date User Action Args
2016-06-27 02:11:19rouiljsetstatus: open -> fixed
priority: urgent
resolution: accepted -> fixed
messages: + msg5649
2016-06-27 01:24:00rouiljsetstatus: new -> open
severity: normal -> major
nosy: + rouilj
messages: + msg5648
assignee: rouilj
resolution: accepted
2009-08-10 22:30:25koweycreate