Roundup Tracker - Issues

Issue 2550729

classification
Title: Anydb backend: Templating Error: 'str' object has no attribute 'dummystr'
Type: crash Severity: critical
Components: Web interface Versions: 1.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: schlatterbeck Nosy List: ber, hemmecke, schlatterbeck
Priority: Keywords:

Created on 2011-09-28 09:00 by hemmecke, last changed 2011-09-28 11:57 by ber.

Files
File name Uploaded Description Edit Remove
str-object-has-no-attribute-dummystr.html hemmecke, 2011-09-28 09:00 Error message.
config.ini hemmecke, 2011-09-28 09:02
Messages
msg4437 Author: [hidden] (hemmecke) Date: 2011-09-28 09:00
I can reliably trigger this error on Ubuntu Natty (Python 2.7.1+)
as well as on Debian 6 (Python 2.6.6).

Find below the exact commands that I issued to install and produce this
seemingly buggy behaviour.

ROUNDUPBASE=/home/hemmecke/scratch/roundup
ROUNDUP=$ROUNDUPBASE/local  ## target directory
ROUNDUPSRC=$ROUNDUPBASE/src ## roundup sources)
V=1.4.19                    ## roundup version number
mkdir -p $ROUNDUPSRC
cd $ROUNDUPSRC

wget http://pypi.python.org/packages/source/r/roundup/roundup-$V.tar.gz
tar xzvf roundup-$V.tar.gz
mv roundup-$V roundup
cd roundup

python setup.py install --prefix=$ROUNDUP
export PATH=$ROUNDUP/bin:$PATH

TRACKERS=$ROUNDUPBASE/trackers
mkdir -p $TRACKERS
cd $ROUNDUPBASE

$ROUNDUP/bin/roundup-admin install
Enter tracker home: /home/hemmecke/scratch/roundup/trackers/foo
Templates: classic, minimal, devel
Select template [classic]: 
Back ends: anydbm, sqlite
Select backend [anydbm]: 

# put the attached config.ini to
# /home/hemmecke/scratch/roundup/trackers/foo
#---------------------------------------------
# or change the original config.ini in the following places:
[main]
admin_email = foo@example.com
dispatcher_email = foo@example.com
email_registration_confirmation = no
[tracker]
web = http://localhost:9112/foo/
email = foo@example.com
[mail]
host = example.com
username = foo
password = secret
#---------------------------------------------

$ROUNDUP/bin/roundup-admin initialise
Enter tracker home: /home/hemmecke/scratch/roundup/trackers/foo
Admin Password: 
       Confirm: 

$ROUNDUP/bin/roundup-server -p 9112 -d $TRACKERS/issues.pid -l
$TRACKERS/issues.log foo=$TRACKERS/foo

#-----------------------------------------------------------------
Point your browser to http://localhost:9112/
Login as admin
Create a new user "foo" (set passwort to 123, set email
log out

log in as new user "foo"
click "Your Details"
enter new password "abc"
enter confirm password "abc"
click "Submit Changes".

After about 3-5 seconds you'll see:
=========
An error has occurred

A problem was encountered processing your request. The tracker
maintainers have been notified of the problem.
=========

The mail text that arrived at my admin account is attached.

Ralf
msg4438 Author: [hidden] (ber) Date: 2011-09-28 09:20
Ralf, thanks for the report and the reproduction instruction.
My next step is to reproduce this myself and see
where this dummystr should come from and how the values are there.
Or do you have any idea what's going wrong here?
msg4439 Author: [hidden] (hemmecke) Date: 2011-09-28 09:34
No idea where this problem comes from.

In fact, originally I installed roundup from a git repository and instead of

wget http://pypi.python.org/packages/source/r/roundup/roundup-$V.tar.gz
tar xzvf roundup-$V.tar.gz
mv roundup-$V roundup
cd roundup
python setup.py install --prefix=$ROUNDUP

did something like this:

cd $ROUNDUPSRC
git clone git://github.com/pypa/virtualenv.git
cd virtualenv
git checkout master
/usr/bin/python virtualenv.py $ROUNDUP
export PATH=$ROUNDUP/bin:$PATH
easy_install -U Sphinx # needed for "setup.py build_doc"
git clone git://github.com/hemmecke/roundup-svn.git roundup
cd roundup
git remote add upstream git://github.com/hemmecke/roundup-svn.git
git config --add remote.upstream.fetch 
'+refs/remotes/svn/*:refs/remotes/svn/*'
git fetch upstream
W=$(echo $V|sed 's,\.,-,g')
git checkout -b release-$W svn/tags/release-$W
python setup.py build_doc
cd $ROUNDUPSRC/roundup
python setup.py install  # no --prefix necessary here

and thought that installing directly from the repository might trigger 
this problem. And it was originally on Debian 6 (i.e. with Python 
2.6.6). Since I've read somewhere that one should not build the roundup 
tarball with python 2.6, I tried on Natty with Python 2.7.
msg4440 Author: [hidden] (ber) Date: 2011-09-28 10:05
Am Wednesday, 28. September 2011 11:34:20 schrieb Ralf Hemmecke:
> Since I've read somewhere that one should not build the roundup
> tarball with python 2.6

Why not? AFAIK python 2.6 is fully supported at least it should be.
msg4441 Author: [hidden] (hemmecke) Date: 2011-09-28 10:12
https://github.com/hemmecke/roundup-svn/blob/master/BUILD.txt#L55

"""(if the last two fail make sure you're using python2.5+)
Note that python2.6 won't correctly create a bdist_wininst install on
Linux (it will produce a .exe with "linux" in the name). 2.7 still has
this bug (Ralf)"""

Oh, according to this, 2.7 would not help, but anyway, as I said:
 >> Since I've read somewhere that one should not build the roundup
 >> tarball with python 2.6
i.e I spoke about creating the tarball not installing from the tarball.
msg4442 Author: [hidden] (schlatterbeck) Date: 2011-09-28 11:04
This is an issue with the anydbm backend. There was a fix for password
display (we don't want to display the encrypted text of password changes
in the history) which didn't fully make it into the anydbm backend. I'm
looking into this now.
msg4443 Author: [hidden] (schlatterbeck) Date: 2011-09-28 11:11
fixed in r4647

Note that this has nothing to do with the windows installer (msg4441),
I'm using python2.5 for creating the installer when doing a release, it
only affects the creation of a binary windows installer (and I *think*
only the name of the generated file will be wrong with newer versions of
python).
msg4444 Author: [hidden] (ber) Date: 2011-09-28 11:55
Thanks both Ralfs for finding reporting and fixing. :)
msg4445 Author: [hidden] (ber) Date: 2011-09-28 11:57
Fixed also verified by "hemmecke" as reported on the devel list.
History
Date User Action Args
2011-09-28 11:57:02bersetmessages: + msg4445
title: Templating Error: 'str' object has no attribute 'dummystr' -> Anydb backend: Templating Error: 'str' object has no attribute 'dummystr'
2011-09-28 11:55:01bersetmessages: + msg4444
2011-09-28 11:11:54schlatterbecksetstatus: new -> closed
assignee: schlatterbeck
resolution: fixed
messages: + msg4443
2011-09-28 11:04:09schlatterbecksetnosy: + schlatterbeck
messages: + msg4442
2011-09-28 10:12:57hemmeckesetmessages: + msg4441
2011-09-28 10:05:30bersetmessages: + msg4440
2011-09-28 09:34:20hemmeckesetmessages: + msg4439
2011-09-28 09:20:30bersetnosy: + ber
messages: + msg4438
2011-09-28 09:02:42hemmeckesetfiles: + config.ini
2011-09-28 09:00:39hemmeckecreate