Roundup Tracker - Issues

Issue 2551009

classification
Title: Flint not supported error during reindex
Type: crash Severity: normal
Components: Documentation Versions: 1.6
process
Status: fixed Resolution: fixed
Dependencies: Superseder:
Assigned To: rouilj Nosy List: gabi, rouilj
Priority: normal Keywords:

Created on 2018-10-12 10:03 by gabi, last changed 2019-06-01 21:31 by rouilj.

Messages
msg6285 Author: [hidden] (gabi) Date: 2018-10-12 10:03
Hi,

I am currently upgrading from a really old roundup instance to 1.6. When
recreating the index with roundup-admin reindex, I got an exception from
xapian that flint is no longer supported. This could easily be resolved
by deleting the index and rebuilding it from scratch. Maybe you can add
a comment in the upgrade documentation? I guess it is always save to
delete the index and re-build it, so this could be helpful advice for
different kinds of problems.

Thanks!
msg6494 Author: [hidden] (rouilj) Date: 2019-06-01 21:31
Hi Gabi:

Thanks for reporting this. I added a section on dealing with the flint 
error to the upgrading doc.

You can see it at rev5751:4c0cdfe4f678 (look at the web page to get the 
link).
History
Date User Action Args
2019-06-01 21:31:42rouiljsetstatus: new -> fixed
type: crash
messages: + msg6494
assignee: rouilj
nosy: + rouilj
resolution: fixed
2019-05-17 00:05:45rouiljsetpriority: normal
2018-10-12 10:03:51gabicreate