Roundup Tracker - Issues

Issue 2551020

classification
Title: GPG/PGP tests fail
Type: behavior Severity: normal
Components: Versions:
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: rouilj Nosy List: ber, cmeerw, mschieder, rouilj
Priority: normal Keywords:

Created on 2019-02-07 17:40 by mschieder, last changed 2019-12-25 01:39 by rouilj.

Messages
msg6330 Author: [hidden] (mschieder) Date: 2019-02-07 17:40
Some GPG/PGP related tests fail.

Installed is python-gpg 1.8.0-3+b2 .

5607:75cfee324d00

./run_tests.py -k PGP -v

platform linux2 -- Python 2.7.13, pytest-2.9.2, py-1.4.31, pluggy-0.3.1
-- /usr/bin/python
cachedir: .cache

collected 1243 items 

test/test_anydbm.py::anydbmDBTest::testPGPNosyMail <-
test/db_test_base.py FAILED
test/test_mailgw.py::MailgwPGPTestCase::testEmptyMessage PASSED
test/test_mailgw.py::MailgwPGPTestCase::testHelpMessage PASSED
test/test_mailgw.py::MailgwPGPTestCase::testPGPEncryptedSignedMessage FAILED
test/test_mailgw.py::MailgwPGPTestCase::testPGPEncryptedUnsignedMessage
FAILED
test/test_mailgw.py::MailgwPGPTestCase::testPGPEncryptedUnsignedMessageCheckBounce
FAILED
test/test_mailgw.py::MailgwPGPTestCase::testPGPEncryptedUnsignedMessageError
FAILED
test/test_mailgw.py::MailgwPGPTestCase::testPGPEncryptedUnsignedMessageFromNonPGPUser
FAILED
test/test_mailgw.py::MailgwPGPTestCase::testPGPSignedMessage PASSED
test/test_mailgw.py::MailgwPGPTestCase::testPGPSignedMessageFail PASSED
test/test_mailgw.py::MailgwPGPTestCase::testPGPUnsignedMessage PASSED
test/test_memorydb.py::memorydbDBTest::testPGPNosyMail <-
test/db_test_base.py FAILED
test/test_mysql.py::mysqlDBTest::testPGPNosyMail <- test/db_test_base.py
SKIPPED
test/test_postgresql.py::postgresqlDBTest::testPGPNosyMail <-
test/db_test_base.py SKIPPED
test/test_sqlite.py::sqliteDBTest::testPGPNosyMail <-
test/db_test_base.py FAILED


=== 8 failed, 5 passed, 2 skipped, 1228 deselected in 10.18 seconds ===


The tests also fail in revision 5494:b7fa56ced601. After this revision
gpg is no longer used but pyme.
msg6335 Author: [hidden] (cmeerw) Date: 2019-02-10 10:43
Do the tests work when updating python-gpg to 1.12.0-6~bpo9+1 (from 
stretch-backports)?
msg6474 Author: [hidden] (rouilj) Date: 2019-05-17 00:01
Magnus Schieder were you able to try updating python-gpg to
1.12.0-6~bpo9+1 (from stretch-backports) as Christof suggested?
msg6491 Author: [hidden] (rouilj) Date: 2019-06-01 16:50
Bern, Do I remember correctly that you were looking into this issue?

If so do you have any findings?
msg6506 Author: [hidden] (ber) Date: 2019-06-03 07:19
Hi John,
so far I haven't been able to investigate more.
My assumption was that it ran with newer versions (but I don't find the
report for it right now, maybe in the CI .)

Bernhard
msg6544 Author: [hidden] (mschieder) Date: 2019-06-13 10:12
I installed python-gpg 1.12.0-6~bpo9+1 and get the same result.
msg6732 Author: [hidden] (rouilj) Date: 2019-10-11 02:43
Christof any ideas, It looks like Magnus is using the version you recommended.
msg6736 Author: [hidden] (cmeerw) Date: 2019-10-12 19:33
Is there any additional output for the failures?
msg6760 Author: [hidden] (rouilj) Date: 2019-10-23 00:27
Magnus, any followup on this? Christof is looking for additional output from the failure.

-- rouilj
msg6792 Author: [hidden] (rouilj) Date: 2019-11-03 22:40
Magnus,

Any further info here?

Also do you have any output from the failures? Usually there is a
source code list that identifies where the test fails.

-- rouilj
msg6853 Author: [hidden] (rouilj) Date: 2019-12-25 01:39
I am closing this. Been a while since Magnus could respond.

I tested this on ubuntu using the python-gpg python3-gpg packages.

python-gpg-1.10.0-1ubuntu2
python3-gpg-1.10.0-1ubuntu2

So older than the last version Magnus tried.

All the tests failing for him are passing for me. Also all these
tests pass CI.

Without more info we can't replicate/diagnose/fix.
History
Date User Action Args
2019-12-25 01:39:04rouiljsetstatus: new -> closed
assignee: rouilj
messages: + msg6853
resolution: works for me
type: behavior
2019-11-03 22:40:27rouiljsetmessages: + msg6792
2019-10-23 00:27:17rouiljsetmessages: + msg6760
2019-10-12 19:33:21cmeerwsetmessages: + msg6736
2019-10-11 02:43:17rouiljsetmessages: + msg6732
2019-06-13 10:12:05mschiedersetmessages: + msg6544
2019-06-03 07:19:55bersetmessages: + msg6506
2019-06-01 16:50:25rouiljsetmessages: + msg6491
2019-05-17 00:01:27rouiljsetpriority: normal
nosy: + rouilj
messages: + msg6474
2019-02-10 10:43:28cmeerwsetnosy: + cmeerw
messages: + msg6335
2019-02-07 17:40:00mschiedercreate