Roundup Tracker - Issues

Issue 2551267

classification
travis ci python 2.7 environment missing GPG testing.
Type: behavior Severity: minor
Components: Test, Infrastructure Versions:
process
Status: new
:
: : rouilj
Priority: low :

Created on 2023-02-27 17:14 by rouilj, last changed 2024-05-26 03:51 by rouilj.

Messages
msg7736 Author: [hidden] (rouilj) Date: 2023-02-27 17:14
Sometime between end of December and mid February CI builds on travis-ci have been failing
when compiling gpgme.

The error is:

    pkg_resources.extern.packaging.version.InvalidVersion: Invalid version: '0.23ubuntu1' 
(package: distro-info)

Ref: https://github.com/pypa/setuptools/issues/3772
     https://stackoverflow.com/questions/75272737/error-invalid-version-0-23ubuntu1-package-
distro-info
     https://bugs.launchpad.net/ubuntu/+source/distro-info/+bug/1991606

I have:

  * verified that setuptools is at a version less than 66
  * tried to install python-gpg (which is not available
      for the ubuntu 20.04 (focal) release but was available for 18.04.
  * apt-get remove distro-info
  * upgraded to gpgme-1.18.0

My guess is something internal to the gpgme  build is upgrading setuptools
or it parsing/calling some underlying routine that is failing.

I verified that setuptools < 66 before the gpgme tarball is unpacked,
configured and built (rev a94e223f1e3e).

On python3 tests, I have worked around this by installing python3-gpg.

GitHub Actions python2 tests on 22.04 ubuntu work.
So we do have gpg testing for 2.7 roundup.

For now I am removing the pip install gpg for python 2.7 on travis.

Maybe fix this when/if we upgrade to ubuntu 22.04 from 20.04 on travis.
History
Date User Action Args
2024-05-26 03:51:47rouiljsetcomponents: + Test
2023-02-27 17:14:03rouiljcreate