Roundup Tracker - Issues

Issue 2550718

classification
Title: Python 2.7.2 amd64 on Windows7: roundup installation failed because of missing registry entries
Type: crash Severity: major
Components: Installation Versions: 1.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: ber, cscortes, rouilj
Priority: Keywords:

Created on 2011-08-11 02:18 by cscortes, last changed 2016-07-10 18:53 by rouilj.

Messages
msg4365 Author: [hidden] (cscortes) Date: 2011-08-11 02:18
1.4.19 of Roundup fails to install with a "No Python installation found
in the registry" error. Latest 2.x version of python is installed
(correctly), and verified it is working.  

using:
roundup-1.4.19.win32.exe
python-2.7.2.amd54.msi
msg4366 Author: [hidden] (ber) Date: 2011-08-11 10:52
Luis,
thanks for trying roundup on windows.
Sorry that you have issues.

I wonder if the amd54 bit version of Python will create a different
registry entry. Do you if one of the older version of roundup worked
with this version of roundup? Or an older version of python?
msg4373 Author: [hidden] (cscortes) Date: 2011-08-14 15:37
Yep, that is the problem.  python for 64 bit/amd does not seem to set
the right registry settings.  Even if I try to install some other python
package, it does not find python. I truly believe the issue is with
python.   I installed the 32 bit version, and roundup installed just fine.

Two more sub-issues:
>  When you go through the install process, you need to run the
installer as administrator (at least on Windows 7).  Otherwise some
registry values do not get set ( it tells you it fails to do so with
error messages).  Don't know why, but the installer should be able to
request administrator or notify the user it needs admin.

> Missing pyWin32, Mark Harmond's windows library for python. I suppose
the installer could check for this and report the missing dependency.  I
have done this myself with DotNet dlls, and some installers give you a
chance to write a routine to check complex missing dependencies. 
Although the easiest way I can think of is wrap an import statement with
a try catch and report either success or failure.  

thanks for the help troubleshooting!
msg4374 Author: [hidden] (ber) Date: 2011-08-15 10:01
Luis,
thanks for retesting, it seems you did found a workaround by using
the 32bit version of roundup?

If so, we should add this to the documentation somewhere.
Don't you think?

Also about the other issues, I think we should split them out into
issue on their own, as they do not seem to be related to Python 2.7.2 
amd64.

What do you think? 
If you agree, can you help to make the split? That would be wonderful!
msg5814 Author: [hidden] (rouilj) Date: 2016-07-10 18:25
I added the following to installation.txt:

-------
If you are using the Roundup Windows installer on a 64 bit system and
you get the error message::

  "No Python installation found in the registry"

you need to install a 32 bit version of python. The 64 bit versions
use a different registry key that the installer doesn't detect. See:
http://issues.roundup-tracker.org/issue2550718 for details.
--------

under Prerequisites.

As of 1.5.0 (IIRC) PyWin isn't needed unless you are running it as a
service. So demo.py and a manual start of roundup-server should work.
See issue2550827 for details.

above is part of commit: 7ea6bbf4286c
msg5815 Author: [hidden] (rouilj) Date: 2016-07-10 18:34
Forgot to mention I also updated installation.txt to document that the
windows installer should be run as administrator to update the registry
properly.

Bern is there anything more to do here?

I don't have any idea how the windows installer works. I assume
it's built using setup.py bdist_wininst??

Is requesting elevation maybe as simple as change the
release directions to include --user-access-control force ?

From: https://docs.python.org/2/distutils/builtdist.html

Starting with Python 2.6, bdist_wininst supports a --user-access-control
option. The default is ‘none’ (meaning no UAC handling is done), and
other valid values are ‘auto’ (meaning prompt for UAC elevation if
Python was installed for all users) and ‘force’ (meaning always prompt
for elevation).
msg5818 Author: [hidden] (rouilj) Date: 2016-07-10 18:53
I am closing this as fixed as I found followups for
the subissues:

issue2550720 - the pywin32 dependency
issue2550719 - run installer as administrator (automatic UAC)
History
Date User Action Args
2016-07-10 18:53:08rouiljsetstatus: new -> closed
resolution: fixed
messages: + msg5818
2016-07-10 18:34:27rouiljsetmessages: + msg5815
2016-07-10 18:25:12rouiljsetnosy: + rouilj
messages: + msg5814
2011-08-15 10:01:53bersetmessages: + msg4374
title: Win 7 & Python 2.7.2 installation failed -> Python 2.7.2 amd64 on Windows7: roundup installation failed because of missing registry entries
2011-08-14 15:37:15cscortessetmessages: + msg4373
2011-08-11 10:52:16bersetnosy: + ber
messages: + msg4366
2011-08-11 02:18:48cscortescreate